Designing for Windows Phone
Contents

LESSON 1
METRO Design
Introduction to METRO design .......................... 5
Alive in motion .................................................. 5
Content, not chrome .......................................... 5
Authentically digital ...................................... 5
Before you start .................................................. 5
Adobe Photoshop phone templates .................. 6
Windows Phone templates .................................. 8
Windows Phone application ................................ 8
Windows Phone Databound application ................. 8
Windows Phone Panorama application ................ 9
Windows Phone Pivot application ....................... 9
The Expression Blend workspace ....................... 10
Exploring the Expression Blend workspace .......... 10
The Artboard ................................................. 11
Changing the view ........................................... 11
Navigating the artboard .................................... 12
The Projects panel .......................................... 12
The Objects and Timeline panel ......................... 13
The Properties panel ....................................... 14
Summary ....................................................... 14

LESSON 2
Building WP7 Assets
Understanding XAML essentials ....................... 16
Creating XAML code ......................................... 17
Making selections in Expression Blend ............... 17
Selection tool shortcuts .................................... 18
Hiding and locking objects in Expression Blend ...... 19
Importing assets into Expression Blend ............... 20
Vector vs. Raster ........................................... 20
Importing native Photoshop and Illustrator files .... 20
Importing an Adobe Illustrator file ..................... 22
Expression Blend drawing tools ......................... 22
Overview of drawing tools for shapes ................. 22
Setting up an application using the Pivot template 22
Using precision tools ....................................... 24
Naming objects in Expression Blend ..................... 25
Applying properties to the rectangle ................... 26
Creating and editing a stroke ........................... 27
Cloning an object ........................................... 27
Adding a stroke ............................................. 27
Resizing the object ......................................... 29
Using the transform pane ................................ 29
Changing the order ......................................... 30
Working with the Pen tool (optional) .................... 31
Drawing straight lines ...................................... 31
Drawing curved lines ....................................... 33
Discovering the direction handles ...................... 33
Creating a s-curved path .................................. 35
Using corner points ........................................ 35
Summary ....................................................... 36

LESSON 3
Layout Controls in Expression Blend
Overview of layout controls .............................. 38
The Grid control ............................................. 38
The Canvas control ........................................... 38
Grid vs. Canvas .............................................. 41
StackPanel control ......................................... 41
Using the Border control .................................. 43
Summary ....................................................... 43

LESSON 4
Creating Animation & Basic Interactivity
Understanding storyboards ............................... 45
Creating storyboard resources ......................... 45
Creating Keyspline animation ........................... 46
Setting storyboard options ................................ 48
Adding easing functions .................................. 49
Behaviors in Expression Blend ......................... 50
What are triggers? ......................................... 50
Benefits of “hand-off” timelines ......................... 51
Summary ....................................................... 52
LESSON 1
METRO Design

METRO Design is based on the signs you see while traveling. Large, eye-popping typography that catches the eye. It places a focus on typography, with all instances using fonts based upon those of the Segoe font family, designed by Microsoft. METRO is designed to be sleek, quick, modern. Something that keeps up with your fast-paced lifestyle.

What you’ll learn in this module:

• Understanding the METRO design experience
• Designing your phone application in Adobe Photoshop
• Styling your phone application
• Understanding the connection between XAML and C# (code behind)
Introduction to METRO design

In this section you discover why you should be inspired by METRO design. The METRO design experience contains the following design principles:

• Clean, Light, Open, Fast
• Feels Fast and Responsive
• Focus on Primary Tasks
• Do a Lot with Very Little
• Fierce Reduction of Unnecessary Elements
• Delightful Use of Whitespace
• Full Bleed Canvas
• Type is Beautiful, Not Just Legible
• Clear, Straightforward Information Design
• Uncompromising Sensitivity to Weight, Balance and Scale

Alive in motion

• Feels Responsive and Alive
• Creates a System
• Gives Context to Improve Usability
• Adds Dimension and Depth

Content, not chrome

• Delight through Content Instead of Decoration
• Reduce Visuals that are Not Content
• Contents is the UI
• Direct interaction with the Content

Authentically digital

• Design for the Form Factor
• Don’t Try to be What It’s NOT
• Be Direct

Before you start

Before you can start working in this tutorial you need to make sure that you have the software required to create a Windows Phone application. Download the free developer tools at http://create.msdn.com/en-US which will either install the expression version of Visual Studio 2010 and a phone version of Expression Blend or if Visual Studio and Expression Blend are already installed, it will just add the new supported project types and the emulator.

There are many methods that you can use to create a Windows Phone application. If your background is as a designer, you might prefer to work in Adobe Photoshop or Illustrator. If your background is in HTML, CSS, or other development you might prefer to jump right into the application Expression Blend, which gives you access to both the mark-up language, XAML and the code-behind (C# or Visual Basic.)

In this lesson, you will start out using Photoshop templates to become more familiar with the terminology and possibilities when working on an application for Windows Phone.
Adobe Photoshop phone templates

You can design a Windows Phone application right in Photoshop using the Photoshop templates. In this first section you will have the opportunity to use Photoshop to create your own application. You will then import your design into Expression Blend.

1. Launch Adobe Photoshop and choose File > Open and browse to locate the folder named WP7Lessons, open the WP7Lesson01 folder located inside and then double-click to open the file named PanoramaControl.psd. A Photoshop document that is created to represent the Windows Phone panorama control appears.

You can use your own templates or any of the supplied templates that are included in the Photoshop Templates folder in the WP7Lessons folder to build a comp for yourself or to be used in proposals. Using the Photoshop templates allows you create your application design in an application that is familiar to you. Later in this session you will discover how to import a native .psd file directly into Expression Blend.

2. Choose Window > Layers to see how you can hide or show layers as needed to help you follow basic specifications and measurements.
3 Turn the visibility on for the Panorama Controls by clicking on the checkbox to the left of the Panels layer. This layer shows the approximate position of each section of the panorama layout.

4 Turn off the visibility of the Panorama Controls layer and then select the phone window layer.

5 Select the Move tool and then hold down the Shift key and click and drag the phone window layer to move the frame across the panorama layout. Notice that in the panorama control frame it is preferable to see part of the next panel, this indicates to the user that there is more content available.

Tip! For more information about UI specifications you can find the Windows Phone Design System - Metro.pdf located in the same Photoshop Templates folder inside WP7Lessons.

6 Choose File > Close, and then choose No.

At this time you will discover the different template possibilities and more about the available controls that you can build for Windows Phone applications.
Windows Phone templates

When working in the Windows Phone development tools you are provided with four default templates. Each template contains its own layout functionality and provides a unique experience for the user. In this lesson you will investigate the following Windows Phone templates:

- Windows Phone Application
- Windows Phone Databound Application
- Windows Phone Panorama Application
- Windows Phone Pivot Application

Windows Phone application

The Windows Phone Application provides you with a simple single page that you can use independently or as an additional screen in your application. In other words, you might want a start-up screen that uses a single phone application page, but has links that go to pivot or panorama screens.

Windows Phone Databound application

The Windows Phone Databound application is a Windows Phone Application page that is referencing sample data. As a default, the initial page has a ListBox control included in the ContentPanel of the MainPage. There is also sample data that you can either delete or reference to your own data.
LESSON 1  Windows Phone templates

**Windows Phone Panorama application**

The Panorama control is new to Silverlight and is a great example of the Metro design guidelines in action. The Panorama provides a way to browse or explore functionality within an application. By aggregating a slice of the different experiences within the application, the Panorama gives you a high-level overview of the detailed tasks available.

![The Windows Phone Panorama template.]

**Windows Phone Pivot application**

The Pivot control is a quick way to access multiple views of data in your application. Opposite of the Panorama control, the Pivot is an “I need to get something done” control used for efficient, focused and habitual tasks.

![The Windows Phone Pivot template.]

Throughout the following lessons you will build applications taking advantage of these templates to start your applications.
LESSON 1

The Expression Blend workspace

In this next section you will discover how to navigate the workspace of Expression Blend. Expression Blend is used to create Silverlight applications for the Windows Phone. Expression blend is also used to create applications for websites, and embedded devices.

The Expression Blend workspace works with a system of tools and panels. The panels can be dragged out of the preset group, or dragged to other panels to create a custom group.

Exploring the Expression Blend workspace

Expression Blend has one of two workspaces: The Design Workspace and the Animation Workspace. Typically, the Design workspace would be used when creating the UI of an application, and the Animation workspace when creating a storyboard, or animation. In this section you investigate the Expression Blend workspace.

1. Start by closing Photoshop now, without saving the changes in the Panorama Control.psd.

2. Launch Expression Blend. If the Welcome screen appears, click on Projects and then click on New Project. The New Project dialog box appears. If the Welcome screen does not appear, choose File New Project to see the New Project screen.
Choose WindowsPhone > Windows Phone Application. Name the project `workspace` and save it in the WP7lesson01 folder and then click OK.

Press `F6` to toggle between the Design View and Animation view. Return to the Design View by pressing `F6` again.

The main difference between the two workspaces are that the Objects and Timeline extends across the bottom offering more room for the timeline in the Animation view. To access the different workspaces you can also choose Window > Workspaces. For this tutorial, you will use the Design Workspace.

Press `F4`, and then press `F4` again. Hiding Panels can be done by selecting Window > AutoHide All Panels command or by using keyboard shortcut `F4` or by pressing the TAB key.

The Artboard
The area in the middle of your workspace is called the artboard, by default it shows you the blank “MainPage.xaml” file. It is the area that is used to visually create the the layout and design for your UI.

Changing the view
On the right side of the artboard are three tabs, the Design tab, the XAML tab and the Split tab.
Clicking on each shows you the respective view. In this section we do not spend much time on XAML, but you should know that this is the language used to create the visual objects in your application.

• Design view shows you what your application will look like when it is built and run.
• XAML view displays the XAML code for your project.
• Split view shows you both.
Navigating the artboard

To navigate around on the artboard, you can use any of the following methods:

- Use the horizontal and vertical scroll bars on the artboard
- Use the mouse wheel to move the Zoom in and out
- Hold down SHIFT while using the mouse to move the artboard horizontally
- Enter a zoom value in the text box at the bottom left of the artboard
- Press Ctrl + (plus sign) or Ctrl - (minus) to zoom in and out of the artboard

The Projects panel

When you are working on a Windows Phone Application you are working with an entire project that includes XAML for creation the visual design and UI and C# to add interactivity and other functionality to your application. To see the parts of your application, also referred to as a Solution, or .sln file, click on the Projects tab.

In the Projects tab you see several files and folders. Later you will create your own folders and add additional files to this solution folder. The files include .XAML files, default image files, and .CS (C# code behind files). All these files are necessary in order for your application to work.

Click on the arrow to the left of the MainPage.xaml file to expose the code behind file that is associated with the MainPage.XAML file. In this next section you will discover what a XAML file is and why it is important in the creation of a Windows Phone application. From the Projects panel you can open files that you want to use for your project, or to add references to other assemblies.

- XAML files (.xaml) open on the artboard. XAML (eXtensible Markup Language) is the markup language for Silverlight which is used to create a Windows Phone application.
- Files that have the extension .cs or .vb will open the built-in code editor, or in Microsoft Visual Studio if it is installed. Essentially, the Blend project system helps you to manage all of your working files and references in an efficient way, keeping them all in a local folder tree within the Projects panel.
- Image files will open in your default image editing application.
The Objects and Timeline panel

The hierarchy of an application, or tree structure is more common in programming environments than in design environments. In the Objects and Timeline panel, a tree will have zero or more child nodes, which are below it in the tree (in the computer world, trees grow down, not up as they do in the natural world). Nodes above the children are referred to as “parent” nodes.

The topmost node in a tree is called the root node. Being the topmost node, the root node will not have parents. In this example the PhoneApplicationPage is at the top level. It is the node at which operations on the tree commonly begin. The first child of this example is the Application Bar, and the first container that can also include children is the LayoutRoot. All other nodes can be reached from the root by clicking on the arrow to the left to expand the node.
LESSON 1

The Properties panel

The Properties panel categorizes properties by type so that you can easily locate a specific property. Locate the Properties panel on the right side of the workspace in the default view. Some categories have an advanced section at the bottom that you can view by clicking on the down-arrow.

You can use the scrollbar to access additional properties.

If you have trouble locating a property, expand all the categories and use the scroll bar along the right side of the Properties panel, or type part of the property name into the Search box at the top.

The name and type of the element that is currently selected under Objects and Timeline appears at the top of the Properties panel. You can expand or collapse categories of properties by clicking the Expand Category button on the title bar of the category, or by simply click the title bar.

1. Using the Tools panel, select the Rectangle tool and click and drag it on the artboard.
2. Click in the Search textbox that is in the Properties panel and type tran (for transform.) Notice that the Transform pane appears.
3. Select the Scale tab, and then click and drag on the value of 1 in the X box. By clicking and dragging you can watch the rectangle change scale as you change the value. You can also click and manually enter a value in these boxes as well.
4. Choose File > Save All, and then File Close.

Summary

In this lesson, you discovered details about METRO design, and how to navigate the Expression Blend workspace.
LESSON 2
Building WP7 Assets

Working with assets from other applications or created directly in Expression Blend makes it easy to create professional and polished User interfaces. In this module, you find out how to import assets already created in applications such as Adobe Illustrator, Photoshop, and Expression Design, as well as create assets directly in Expression Blend.

What you’ll learn in this module:
• Tips and tricks for smooth integration of assets
• Organizing and naming layers
• Known issues, and how to address them
• Naming conventions and best practices
• Working with basic drawing tools in Expression Blend
• Grouping and naming items in Expression Design
• Importing XAML from Expression Design
Understanding XAML essentials

XAML is a declarative language used in Silverlight to create UI, such as controls, shapes, text, and other content presented on the screen. If you're familiar with Web programming, you can think of XAML as similar to HTML, but more powerful. Like HTML, XAML is made up of elements and attributes. However, XAML is XML-based and therefore must follow XML rules, which includes being well formed. Even though Expression Blend writes the XAML code when you create your visual elements on the artboard you will, at some time, want to investigate or tweak the XAML. XAML separates code from design and enables both designers and developers to iterate rapidly in parallel without impacting the work of the other.

In this next session you gain some experience in understanding and using XAML.

1. In Expression Blend, choose File > New Project. Choose Windows Phone > Windows Phone Application. In the New Project window that appears type the name **Project03** and then press OK.

2. Select the Rectangle tool from the Tools panel and click and drag a rectangle anywhere on the artboard.

3. Click on Split to view the Design and the XHTML view simultaneously.

Notice that the XAML code for a rectangle is rather straight forward, `<Rectangle/>`. The additional code that follows contains the attributes such as size and color. These are also referred to as Properties.

Everything you create on this page will be nested inside of an element named PhoneApplicationPage. Inside of PhoneApplicationPage there's an element named "Grid". Don't worry at this stage about what these elements do, just be aware that they are the parent elements of all the content you create.
In the code view remove the hexadecimal number following Fill in the Rectangle tag and then replace it with the word **RED**. The rectangle is now red. You can edit in both the Design or Code view when working in XAML.

5 Press Ctrl+S to save this file. Keep it open for the next exercise.

**Creating XAML code**

In this next section, you will add a button control to your application by typing in the XAML code view.

1 With the same Project03 document open, click to insert the cursor after the Rectangle tag.

```
<Button Width="200" Height="100" Content="Go"/>
```

Type in the code to create a button along with some attributes.

Notice that Intellisence appears in order to help you select the correct code.

2 Click on the Design view to see your completed button.

3 Press Control+S to save the file, and then close the file.

**Making selections in Expression Blend**

Before you get started making your own project, it is a good idea to spend a few minutes investigating methods of selecting objects in Expression Blend. To do this, you will use a sample file that has already been created to help you to activate objects and to re-organize their stacking order.

Making the correct selection in Expression Blend is important, especially when you are changing properties. In this next part of the module, you'll find tips and tricks to help you make changes to the right objects.

1 Launch Expression Blend. If the Startup dialog box appears, you can choose Open Project, or you can select File > Open Project/Solution.

2 Navigate to the WP7lessons folder and open the WP7Lessons02 folder.
Once in the WP7Lessons02 folder open the SelectionExercise project folder, and select SelectionExercise.sln. A simple file with two buttons appears.

Notice, in the Objects and Timeline panel, that for every object on the artboard there is a related object in the Objects and Timeline panel; in this example there are simply two buttons. You will name these properly in the next steps.

Click on the Selection tool and then click on the button that says Move on the artboard. Notice that as you select that object, the selection is also indicated in the Objects and Timeline panel.

With the Move button still selected look for the Name textbox at the top of the Properties panel, and type **MoveButton** into the TextBox.

Now select the object named [Button] in the Objects and Timeline. Notice that you are able to select from both the artboard or the Objects and Timeline panel.

Double-click on the name [Button] in the Objects and Timeline and type in the name **PauseButton**, then press the Enter key.

**Note:** When working in Expression Blend you can name objects in the Properties panel or by double-clicking on the object in the Objects and Timeline panel.

Choose File > Save All and then keep the file open for the next part of this lesson.

**Selection tool shortcuts**

There are two selection tools that you can access via the Tools panel, or by using the keyboard shortcut (in parenthesis):

- Selection tool .............................................. (V)
- Direction Selection tool .............................. (A)
- Select All .................................................. CTRL+A
- Select None .............................................. CTRL+SHIFT+A
Designing for Windows Phone

LESSON 2  Hiding and locking objects in Expression Blend

Hiding and locking objects in Expression Blend

Note that you can turn off the visibility and lock objects in the Objects and Timeline panel. Keep in mind that the objects still appear when your application is run, this is simply a method for helping you organize your objects while you are developing your application.

1  Click on the Eye icon to the icon to the right of the MoveButton object in the Objects and Timeline panel to hide the Move button on the artboard.

![Objects and Timeline panel](image)

2  Press F5 to run your project. Once the solution file is built it opens automatically in your default browser. Notice that the Move button is still visible.

3  Return to Expression Blend and make sure that the MoveButton object is still selected in the Objects and Timeline panel, then go to the Properties panel and locate the property named Visibility that is located in the Appearance pane.

![Properties panel](image)

4  From the drop-down menu choose Collapsed, and then press F5 to run the application again. Note that now the Move button does not appear. The visibility property can be used throughout your application and can be triggered by any number of events, which will be covered later in Lesson 3, “Naming and Arranging Elements in Expression Blend.”

5  From the Appearance panel change the Visibility property back to Visible for the Move button.

6  Choose File > Save All. Keep this file open for the next part of this lesson.
Importing assets into Expression Blend

You discovered the relationship between the objects created in Expression Blend and the underlying XAML code. In this section, you go a step further by taking advantage of graphics that already exist to create your XAML code in Expression Blend.

Vector vs. Raster

Expression Blend supports both Vector and Raster graphics, and both can be included in the same project file.

Vector objects are geometry-based shapes and lines with editable lengths, widths, locations, and colors. They are resolution-independent. This means the quality of the image is dependent upon your output resolution, rather than a predefined resolution. Vector objects can be scaled in size without degrading the quality of the image.

A raster image, such as one created in an application like Photoshop, has a pre-defined resolution. A raster image is made up of pixels, which are not mathematically redefined as you scale the image. This, of course, can lead to degradation of your file if scaled beyond a safe range of 50% smaller to 110% larger.

Importing native Photoshop and Illustrator files

In the first part of this module, you will take the existing SelectionExercise project file and import a layered native Photoshop document into Expression Blend.

1. In Expression Blend make sure that you still have the SelectExercise file open. If not, choose File > Open Project/Solution and navigate to the WP7Lesson02 folder and double-click to open the SelectionExercise project folder, then expand the SelectionExercise folder and double-click on the MainPage.xaml file in the Project panel.

2. Click on the LayoutRoot in the Objects and Timeline panel to make sure it is the active canvas.

3. Choose File > Import Photoshop File, navigate to the WP7Lesson02 folder and double-click on the PhoneDesignSample.psd file. The Import Adobe Photoshop File dialog box appears.

   Using this dialog box, you can turn off and on the layers that you want to retain, or, choose to merge some or all the layers.
4 Uncheck the black background layer, then click OK.

5 The Photoshop file is opened in the Windows Phone project, and placed in the Objects and Timeline as a canvas named PhoneDesignSample. Don't worry if your buttons have been repositioned, they will snap back in place after the image is repositioned.

**Note:** Adobe Photoshop files must be saved in the RGB format in order to import into Expression Blend. Also note that Photoshop effects are not compatible with Expression Blend and may be ignored.

6 Look at the new canvas named PhoneDesignSample located in the Objects and Timeline panel, and expand it to see the named layers are now canvases contained within.

7 Collapse the PhoneDesignSample canvas, and then select the canvas in the Objects and Timeline.

8 Make sure that you have the Selection tool active and then click and drag on the PhoneDesignSample canvas to reposition it in the middle of the screen. Exact positioning is not important.

9 Press Ctrl+S to save this file, and keep it open for the next part of this lesson.

**Note:** Adobe live effects, blend modes, and the symbol sprayer are not supported. When you import an Adobe file, Expression Blend Preview will display a message to let you know if any features of the imported file are not supported, and what actions you can take.
Importing an Adobe Illustrator file

In this next section, you will take artwork created in Adobe Illustrator and import it into the SelectionExercise project in Expression Blend. This is an excellent workflow, as it allows designers to work in a software package that already has well-developed precision drawing tools.

1. Select the ContentPanel in the Objects and Timeline panel and then choose File > Import Adobe Illustrator File. The Import Adobe Illustrator File dialog box appears.

2. Navigate to the WP7Lesson02 folder and double-click on the file named arrows.ai file. The file is placed as vector artwork in Expression Blend.

3. Using the Selection tool, click on the arrows canvas (not the layer that is inside the arrows canvas) and click and drag the artwork to the bottom center section of the screen. Exact positioning is not important at this time.

4. Press Ctrl+S to save this file, and then choose File > Close to close this project. After discovering how to create storyboards (animations) and use behaviors you can go back and make this a functioning application.

Expression Blend drawing tools

You don't have to have an Adobe Illustrator or Photoshop file in order to use graphics in your Silverlight Project; you can create shapes using the drawing tools directly in Expression Blend. In this part of the module, you will discover how to create shapes and apply attributes to them, as well as how to use the Pen tool for custom paths.

Overview of drawing tools for shapes

You can use the shape tools in Expression Blend to make simple rectangles, ellipses and lines. Using the Brushes pane in the Properties panel you can then edit the fill and stroke. In this next section, you will create a rectangle with rounded corners and filled with a gradient.

Setting up an application using the Pivot template

In this section you create a Pivot phone application and discover how to set-up the PivotItem control so that you can add your own custom artwork.
1 Choose File > New Project and select Windows Phone > Windows Phone Pivot Application. Name the project **Lesson02Shapes**. Make sure that you are saving into the WP7Lesson02 folder and press OK.

The pivot template is different than the Phone Application template that you used in the previous exercise. The pivot works well for applications that require lots of data. You can add multiple pivots to an application.

2 Expand the LayoutRoot and [Pivot] to see the additional PivotItem controls.

3 Expand the first [PivotItem] to see that a ListBox with sample data has been automatically included with this template. In this case we do not require this ListBox.

4 Click on the FirstListBox object in the Objects and Timeline panel and then press Delete on the keyboard to clear it off the artboard. You can leave the ListBox in the second PivotItem.

As you work more in Expression Blend you will discover that there are a great number of differences in how layout controls work. In this case you have a PivotItem that can hold a child object, much like the ListBox that you just removed. But the PivotItem can only hold one item.

5 Select the Rectangle control from the Tools panel and click and drag on the artboard.

6 Now click and drag another Rectangle into the same control. Note that you do not receive an error, but your original rectangle disappears and is replaced with the newly created rectangle. To allow
you to put multiple objects into a control that only allows one object you can use a layout control such as a Grid, or canvas. In this example, you will use a canvas.

7 Select the rectangle that is on the artboard and press the Delete key on the keyboard.
8 Click and hold on the Grid on the Tools panel and select the Canvas control.
9 Click and drag a canvas out into the top PivotItem.
10 You can manually resize the canvas to fit the PivotItem, or you can simply click on the Advanced Properties button to the right of Margin (in the Layout pane that is in the Properties panel) and select Reset.
Since the canvas can hold multiple items you will now be able to add more than one shape to the PivotItem.

Using precision tools
To help build a more precise project you can opt to turn on the snap grid. If you do not see some of the options described below, choose Window > Reset Current Workspace.
1 Look at the bottom of the workspace for buttons that can aid you when building your UI in Expression Blend. Click on the Show snap grid button in the lower left of the Expression Blend workspace; a grid appears.

In this example, you will keep the grid settings at their default, but keep in mind that you can change the appearance of the grids in the Options dialog box by choosing Tools > Options > Artboard.

Tip: It is a good habit to activate the container in which you want an object to be in before you draw the object. If you forget to do this you can click and drag an object in the Objects and Timeline panel into the correct layout container at anytime.
2 Click and hold on the Rectangle tool in the Tools panel. Note that any of the tools that have a triangle in the lower right corner have additional tools that are hidden. In this case, you can see that the Ellipse and Line tools are the hidden tools behind the Rectangle tool.

3 With the Rectangle tool selected, hold down the Alt key and click and drag from the approximate center of the PivotOne canvas. It does not have to be exact, as the position can be changed later. Note that by holding down the Alt key, you are creating this shape from the center, rather than from the upper left. Click and drag until the values in the handles indicate that the rectangle is approximately 100 pixels high and 100 pixels wide. Again, this does not have to be exact.

Tip: If you do not see the measurement values as you drag press F9, or choose View Object > Show Handles.

4 If necessary, reposition or resize the rectangle by choosing the Selection tool and drag to resize from one of the corners.

5 Press Ctrl+S to save your project, or choose File > Save. Keep the project open for the next part of this exercise.

Naming objects in Expression Blend

At some point, objects need specific names, particularly when you make the transition to an interactive application. With XAML, naming logic can be applied to these elements to reduce any potential confusion and to make these elements identifiable to collaborators. (Even if it's just a team of one!).

Working with the button names in the first column is much more preferable to working with those in the second column. Reaching an agreement on naming conventions early in the development process will help the team avoid confusion later when integrating work from different designers and/or developers.

<table>
<thead>
<tr>
<th>Good Names</th>
<th>Bad Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>btnPlay</td>
<td>button1</td>
</tr>
<tr>
<td>btnPause</td>
<td>button2</td>
</tr>
<tr>
<td>fullScreen</td>
<td>button3</td>
</tr>
<tr>
<td>btnPlaylist</td>
<td>button4</td>
</tr>
</tbody>
</table>

Note: In XAML, you can only use one particular name with one object, and that names need to be unique to maintain good naming conventions.

In this situation, it would be best if we name the control background so that we can locate it later, whether working in code, or in the Expression Blend Design View.
LESSON 2
Applying properties to the rectangle

1. Using the Selection tool, click on the rectangle you just created.
2. If you cannot see the Objects and Timeline panel, choose Window > Objects and Timeline.
3. Click twice on the object name [Rectangle], and type the name **MyRectangle**.
4. Press Ctrl+S to save your project, or choose File > Save. Keep the project open for the next section.

**Applying properties to the rectangle**

You will now apply a gradient to the rectangle.

1. With the Selection tool, click on the rectangle to make sure it is active, or click on the MyRectangle object in the Objects and Timeline panel.

   The Properties panel offers you the opportunity to apply Fill Brushes as well as Stroke Brushes. You can select different colors, and gradients in which you can set the fill or stroke an object. In this example you will set the fill of the rectangle to be solid.

2. Click on Fill, which is under Brushes, in the Properties panel. Then click on Solid color brush and then click on any color in the color panel.

3. Press Ctrl + S to Save the file. Keep the file open for the next part of this lesson.
Creating and editing a stroke

Your next step will be to remove any stroke that might already be applied to the original rectangle and then clone it for a different stroke effect.

1. In the Objects and Timeline panel, click on the MyRectangle object to select it.
2. If the Properties panel is not visible, choose Window > Properties, and then look for the Brushes pane. Click on Stroke, and then click on the No brush icon. This eliminates any stroke that may have been applied.

![Remove the stroke from the rectangle.](image)

You will now clone the MySquare object, resize it and apply a stroke to it.

Cloning an object

In this example you will copy the rectangle and simply cut and paste to create an identical object on the artboard.

1. Using the Selection tool, click on the MyRectangle object.
2. Choose Edit > Copy to copy the object, and then choose Edit > Paste. Expression Blend positions the copy of the object exactly on top of itself.
3. To make it easier to identify this new object, go to the Objects and Timeline panel and double-click on the MyRectangle_Copy object and type the name **MyRectangle02**.
   
   **Tip!** You can also clone by choosing the Selection tool, and then holding down the Alt key while dragging the object.

Adding a stroke

In this next section you will add a stroke to the new rectangle and change the color and stroke thickness.

1. With the Selection tool click on the MyRectangle02, in the Objects and Timeline panel, and then click on Stroke in the Properties panel.
2. Click on the Solid color brush button and then click on any color in the color panel.
3 In the Appearance pane, click and drag in the StrokeThickness textbox to set a width. You can assign any width. The stroke appears in the color that you selected.

You will now round the corners using guides that are visible in the artboard.

4 Note that when the MyRectangle02 is selected, guides appear in the upper-left corner of the object. These guides allow you to visually create rounded corners.

5 Click and drag on one of the guides to form rounded corners.

6 Press Ctrl+S to save this file, keep it open for the next part of the lesson.
Resizing the object

You will now resize the MyRectangle object.

1. Make sure that you still have the Selection tool active and click on the MyRectangle, either on the artboard, or in the Objects and Timeline panel.

   You will first resize without adding a modifier key to see how a typical resize function occurs. You will then resize using a combination of modifier keys to see how you can better control a resize.

2. Click on any corner of the MyRectangle and drag inwards. Notice that object is resized, but not in any precise mode.

3. Press Ctrl+Z, or Edit > Undo to put the rectangle back to its original size.

   **Tip:** You can press Ctrl+Z to undo multiple steps. Press Ctrl+Shift+Z to redo a step that you may have inadvertently undone.

4. Now, hold down the Shift+Alt keys simultaneously to resize the object, keeping the same proportions and resizing on all sides inward. Simply make the rectangle about 75% of the original rectangle; an exact measurement is not necessary for this exercise.

5. Keep MyRectangle selected for the next part of this lesson.

Using the transform pane

1. If you do not see the Transform pane in the Properties panel, click and drag the scroll bar down, or type Tran in the Search textbox at the top of the Properties panel.

   ![Image of Transform pane](image)

   *To see all the panes in the Properties panel, you need to scroll.*

   In the Transform pane, you see tabs for several transform methods which you can use.

   ![Image of Transform pane](image)

   *Use the Transform pane for multiple transforms.*
LESSON 2  Changing the order

2 If you do not see the Transform types, click the arrow to the left of the word Transform in the pane tab, and then click on the Scale transform tab.

3 Individually, click and drag the X and Y textboxes (to the left) until each value is set to 0.9 (90%). You have now scaled an exact percentage.

4 Press Ctrl+S to save your project, or choose File > Save. Keep the project open for the next section.

Changing the order

Up to this point, you have been simply adding objects to the phone project with no concern as to its order in appearance. The Objects and Timeline panel is helps to identify the parent and child order of containers and objects in the project. If you look at your Objects and Timeline panel, you will see that the stacking order might be considered the opposite of what you might expect (if you typically use graphics applications). That is because the stacking order in the Objects and Timeline panel starts at the bottom. Meaning, the object at the top of the stacking order is actually at the bottom of the visual stack.

1 Click and drag the MyRectangle02 shape in the artboard on top of the original MyRectangle to see that it is on the top of the stacking order. Notice that in the Objects and Timeline panel it is at the bottom of the stack. This is typical for development, as the last code entered is the topmost object in the application.

2 Right-click on the MyRectangle02 and choose Order > Send to Back. The MyRectangle02 object is now on the top of the stacking order in the Objects and Timeline, but behind the MyRectangle object on the artboard.
   It is best to get used to this method of arranging objects, but if you would rather see the stacking order arranged by Z-order, click on the Arrange by Z-order button ( ) in the lower-left of the Expression Blend workspace.

3 Choose File > Save and then File > Close.
Working with the Pen tool (optional)

You discovered how to import vector paths when you imported an Adobe Illustrator file, as well as edit the existing shapes in Expression Blend. In this section, you have an opportunity to find out how the Pen tool works, allowing you to create your own custom shapes.

Drawing straight lines

The first Pen tool technique to discover is how to create a straight line. To do this, you create individual anchor points by clicking with the Pen tool. Since you need to keep your other Expression Blend project open, you will have to re-launch another instance of Expression Blend so that you can practice.

1. From Expression Blend choose File > Open Project/Solution, and then browse to locate the folder named WP7Lesson02 in the WP7Lessons folder. Open the folder named PenExercises and double-click on the PenExercises solution file within. Expression Blend launches and an artboard appears with some paths already on it. You will use this artboard for practicing with the Pen tool.

   Note: If you do not see the file appear, locate the Properties panel, and double-click on the MainPage.xaml file.

   ![The Pen tool exercise file.](image)

2. In the Objects and Timeline panel select the canvas named practice. This canvas has been created so that you can delete and restart the exercise at anytime without destroying the underlying exercise paths.
LESSON 2  Working with the Pen tool (optional)

3 Select the Pen tool (驷) from the Tools panel and locate Path 1 on the left side of the artboard. Click and then release on the top endpoint to begin your path.

![Path 1](image1)

*Use the Pen tool to create the first anchor point.*

4 Position your cursor (don't click yet!) over the second point in the zig-zag, and then click. This connects the first point with the second. If you work in Adobe Illustrator this concept is very familiar to you, but if you typically create paths in code, this is a new method to learn.

![Create the second anchor point.](image2)

5 Continue to click and release to complete the zig-zag. Notice how the Pen tool automatically continues the line to include each new anchor point that you designate.

6 After you have set a final anchor point, press and hold the Ctrl key and click on any empty area of the artboard. This deselects and ends the line. If you don’t deselect the line, the Pen tool continues to link the line you just created to any anchor points that you create.

7 Position the cursor over the top end point of Path 2. Click and release the left mouse button to create the first anchor point of the new line.

![Creating straight lines in path 2.](image3)
8 Position the cursor over the next anchor point. Hold down the Shift key, then click and release to create the second point of the line; the Pen tool automatically connects the two points with a straight line.

9 Position the cursor over the next anchor point. Again hold the Shift key and click and release the left mouse button to set a third anchor point. This time, the line created is on a 45 degree angle. By holding down the Shift key, you can create lines that are straight, vertically, horizontally, or on 45 degree angles.

10 Continue holding down the Shift key and clicking with the Pen tool to complete Path 2.

12 Hold down the Ctrl key and click on the artboard to deselect and end the line. Choose File > Save.

Drawing curved lines

Straight lines can only take you so far; more organic and complex compositions require you to use curved lines to render subjects. You will now complete Path 3.

Discovering the direction handles

When you select or create a smooth point, you can see the direction handles of that point. Direction handles control the angle and length of curves. Direction handles comprise two parts: direction lines and the direction points at the ends of the lines. An anchor point can have zero, one, or two direction handles, depending on the kind of point it is. Direction handles serve as a kind of road map for the line, controlling how the lines approach and leave each anchor point. If the exiting handle is downward-facing, the line leaves the anchor point and goes down. Similarly, the line faces upwards if the direction handle is pointing upwards.
1. Position your cursor over the first anchor point in Path 3. Click and, without releasing the mouse, drag your cursor up slightly above the arc to create your first anchor point. As you drag your cursor up, it looks like you are dragging a line away from the point. You are, in fact, creating a direction handle for the anchor point.

![Dragging while clicking with the Pen tool allows you to create direction handles.](image1)

2. Place your cursor over the second anchor point, located at the end of the first curve in Path 3. Click and drag straight down to create the second anchor point. Continue to drag the mouse until you form the curve in the template.

As you drag your cursor down, notice that a curve is being formed between the two anchor points. As long as you do not release the mouse button, you can reshape this line by dragging the mouse in different directions.

![Dragging while creating the second anchor point allows you to curve the path.](image2)

If you need to modify any of the previous points, choose Edit > Undo or use the keyboard shortcut, Ctrl + Z. Do not worry if the curves do not follow the template perfectly, they can be adjusted in the next step.

3. Switch to your Direct Selection tool, and click on one of the two anchor points that you created. These are the points that you clicked and dragged to make the curve. Notice that the directional lines appear when an anchor point is active.
Click on the end point of the directional line and click and drag in any direction. Notice that you can adjust these lines after the anchor point has been placed in order to fine-tune a path.

Select the Selection tool (solid arrow) and click off the active path to make sure that it is not longer active.

Creating a s-curved path
Now you will create the curved path that you see in Path 4.

1 Select the Pen tool.
2 Place your cursor over the first point on Path 4. Click and drag up to create an anchor point to make the first directional line that will form the second curve in the template.
3 Click and drag down on the second point to create the first arch, then by clicking and dragging up or down, complete the curved path.

When your path is completed, hold down the Ctrl key and click anywhere on the artboard where there are no existing paths to end the path.

If necessary, use the Direct Select tool (s) to reposition the handles and points so the curves follow the path more closely, then choose File > Save to save your work.

Using corner points
In the previous exercise, you created S-curves, lines curved in the opposite direction from the previous one. In this exercise, you will create corner anchor points, lines that curve in the same direction; in this case, they will all curve up like a scallop.

Select the Pen tool and then position your cursor over the first point in Path 5 (at the beginning of the curved line.) As you did in the previous exercise, click and drag your cursor up slightly above the arc of the line to create your first anchor point.
2 Place your cursor over the second point, located at the end of the first curve. Click and drag straight down to create the second anchor point. Continue to drag the mouse until you form the curve in the template.

3 Press and hold the Alt key on the keyboard. This temporarily changes the Pen tool to a tool that can convert curved anchor points into corner points. Holding down the Alt key, position the Pen tool over the direction point for the existing direction line, and click and drag this point so that it points upward. The two direction lines now are pointing upwards.

4 Release the Alt key and position your cursor over the third point in the path. Click and drag straight down to create the third anchor point. Continue to drag the mouse until you form the curve in the template.

5 Press and hold the Alt key. Once again, position the Pen tool over the direction point for the exiting direction line, and click and drag this point so that it points upward and the direction lines form a V.

6 Repeat step 4 for the final curve at label 4. After you have created this final anchor point, hold down the Ctrl key and click on the artboard.

7 Choose File > Save to save your work. You can now choose File > Close All Documents for this project.

Summary

In this lesson you discovered how to import objects into Expression Blend from other applications, as well as how to create custom assets directly in Expression Blend.
Layout Controls in Expression Blend

Before you get started creating Windows Phone applications in Expression Blend, you’ll need to tackle one of the most fundamental aspects of the XAML workflow: Layout Controls. If you’re familiar with XHTML and CSS, many of the XAML layout controls will be intuitive for you. If your main experience with layout is print or Flash based, you’ll need to learn some basic concepts in order to fully grasp the purpose and proper roles of the XAML layout controls.

What you’ll learn in this module:

- An introduction to layout controls
- Difference between Grid and Canvas
- Using StackPanels and Borders
Overview of layout controls

In XAML, there are many different layout controls which are used to organize content in an application. For instance, StackPanels are used to align and distribute objects evenly, Grids provide a structural framework for a UI using rows and columns, and Canvases are handy for situations where you need exact positioning.

Keep in mind that XAML layout controls can be nested inside each other, so you may have a StackPanel inside a Grid or a Canvas. In this section, you’ll be exploring layout elements and discovering which control would be best to use depending upon the scenario.

The Grid control

Grids resemble HTML tables in the sense that content can be structured in rows and columns. The real power of the Grid control though, is the degree of precision available for managing the relationship between content and container.

A typical example of a grid in practice would be an expandable UI. If you are working on a computer right now, most likely the program you are using allows you to resize the workspace window. When you do so, the panels and tools of the UI rearrange themselves to compensate for the available screen space. Generally the document window will become smaller, but important high level elements like the main menu remain visible. Creating UI’s with expandable layouts is achieved using the Grid layout control.

The Canvas control

The closest element to a XAML Canvas Control in XHTML is a <div> tag with a number of absolutely positioned elements inside. Instead of a table-like grid structure where child elements live inside of cells, a canvas simply lets you position child elements like you were rearranging furniture or tacking pictures to a wall. You probably aren’t expecting the floor or walls to change dimensions, so you aren’t thinking about how your pictures and furniture are going to react in that scenario.

You will now create a Grid control of your own.

1. Launch Expression Blend and choose File > New Project and select Windows Phone > Windows Phone Application.
2. Name the file GridProject and choose to save it in the WP7Lesson03 folder.
3 Select the Grid control from the Tools panel and select LayoutRoot in the Objects and Timeline panel, and then click and drag to create a grid in LayoutRoot container.

4 Double-click on the name [Grid] in the Objects and Timeline panel and rename the new grid MainGrid.

5 With the grid still selected, add three rows by clicking once for each row in the blue strip to the left of the grid. It is not important to have these rows at any specific location, just provide space where you can put an object in the row later in this lesson.

6 If you need to adjust the rows, click and drag on the rows in the same blue strip that you used to add new rows. If you need to remove rows, simply double-click on them. Note that if you delete your rows that you will want to create them again before moving forward in this lesson.

**Tip:** After you double-click to remove a row, move your mouse away from the grid to see that the row has actually been deleted.
7 Click on MainGrid in the Objects and Timeline panel.

8 Select the Rectangle tool in the Tools panel, and click and drag a rectangle element in each one of the rows. You may re-adjust the rows by clicking and dragging on them if necessary. Again, do not worry about the size of these rectangles.

9 Lock the top row, by clicking on the padlock icon that is to the left of the row.

10 Choose the Selection tool and then click and drag the lower-right handle of the MainGrid. Notice that while the bottom two rectangles re-size, the top rectangle’s height remains intact in size.

![Click and drag the corner to resize the grid.](image)

Of course, the benefit of using a grid control is that you can control the resizing of certain elements in your project. This offers users the opportunity to resize some of an application’s controls, but not all the controls.

11 Select one of the rectangle elements, and notice the chains on either side of the grid. You can take advantage of these chains to lock down positioning of an element in a grid.

12 Click on the bottom chain to break the chain icon. Essentially, by breaking the bottom chain you have indicated that the spacing between the object and the row beneath are flexible and can change. The top margin, on the other hand, will now remain fixed.

![Click to break the chain icon.](image)

13 You can test the link by clicking and dragging the grid to be larger or smaller. Notice that the top margin (between the grid row and the top of the rectangle) stay the same, while the bottom area grows or shrinks as you drag the grid to various sizes.
Grid vs. Canvas

Now that you have some perspective on the Canvas and Grid controls, it’s a good idea to think a little bit about which scenarios might be most appropriate for each. The Grid control is good for more complex UI layouts. In the last section, you recreated the Expression Blend UI as an example of the power and flexibility of grids. As a general rule, Grids should be used in any situation that needs a flexible layout, like a browser application. This could mean an entire application interface, or perhaps just simple windows and pop-up screens.

A canvas is more appropriate when you do not need the flexibility of a structured UI, and would work well for a fixed UI size, like what you work with when creating a phone application. In the next section you’ll begin to explore some of the layout controls that serve more specific and explicit purposes.

As another general rule, if you aren't creating a UI that would require a grid, or one of the controls featured in the next section, there's a good chance you'll want a canvas. In fact with phone applications that cannot be resized by the user, the canvas control would most likely be the best solution.

StackPanel control

Using the StackPanel control you’ll be able to easily create layout controls that help you to align and distribute the objects within. In this lesson you’ll use default buttons and a StackPanel to quickly create a navigation panel.

1. Create a new Expression Blend project by selecting File > New Project > Windows Phone > Windows Phone Application.
2. Change the name to StackPanelProject and save it in the WP7Lesson03 folder.
3. Select the StackPanel, hidden in the Grid tool in the Tools panel.

Note: The Tools panel will display the last used layout container as a default.

4. Click and drag anywhere on the artboard to draw a StackPanel that is about 300 pixels square. Don’t worry about an exact size, you will be adjusting it later in this lesson.
5. Select the Button control from the Tools panel, and click and drag to create a button inside of the StackPanel. Don’t worry about the exact size of the button.
6. Now, choose Edit > Copy. Click on the StackPanel control in the Objects and Timeline and press Ctrl+V to paste another button into the StackPanel. Notice that the newly pasted button stacks below the original button.
Press Ctrl+V to paste again. Notice how the buttons stack one on top of the other. If necessary, select the StackPanel and then the Selection tool and resize it to see all three buttons. Now you will change the orientation of the StackPanel.

Using the Selection tool, select the StackPanel. In the Properties panel, look for Layout and select Horizontal from the Orientation drop-down menu. Now the buttons line up next to one another.

Using the Selection tool, resize the stack panel to accommodate the horizontal layout and keep the bottom and top edges somewhat close to the buttons.

To adjust the margins, select one of the buttons in the Objects and Timeline panel and then Ctrl+click on the other two to select all three buttons.

In the Layout pane click on Advanced Options to the right of Margin and select Reset to reset all margins to zero.

In the Layout pane of the Properties panel, type 10 in the Left margin field.

Adjust the left margin of the buttons.
Using the Border control

Just like the StackPanel control stacks, the Border control can add a border. In this example you will group the StackPanel into a Border control. Grouping one container inside another is a great method to help you organize sections of your application while you are building it.

1. Right-click on the StackPanel in the Objects and Timeline panel and select Group Into > Border. You’ll now to add a brush stroke to see the Border control.
2. In the Brushes pane of the Properties panel select BorderBrush and then select the Solid color brush.
3. Change the color to #FFFFFF (white)
4. Select Background and then select No brush. In addition to simply adding a border, this control allows you to control each edge and corner individually.
5. In the Appearance pane of the Properties panel set the Top, Right, Bottom, and Right BorderThickness to 3.

6. In the corner radius field enter 0, 10, 0, 10. This starts applying a corner radius in the top-left and then works its way around clockwise.

7. You are done with this file, you can choose File > Close All Documents. When the Expression Blend dialog box appears, press Don’t Save.

Summary

In this lesson you discovered the differences between the most popular layout containers, which are Grid, Canvas, StackPanel, and Border and when it is appropriate to use each.
LESSON 4

Creating Animation & Basic Interactivity

The heart of animation and motion in a WP7 application is the Storyboard, which provides a timeline on which objects can move and transform over a given time period. Storyboards can be created from the Objects & Timeline panel, and you can create as many Storyboards as you’d like within your project.

What you’ll learn in this module:

• An Introduction to Silverlight Storyboards
• An Introduction to Easing & Easing Functions
• Controlling Storyboards with Behaviors
• Advantages of Handoff Timelines
• Applying Perspective Transformation
Understanding storyboards

If you’ve ever created animation in Flash or other applications, you’re already familiar with the concept of animating objects on a timeline. Unlike Flash, however, there is not a main timeline in Expression Blend – any timelines (storyboards) must be created by you.

Creating storyboard resources

In this lesson, you will take an existing project and add storyboards to create several animation sequences. Later, you’ll create triggers that will allow you to switch between these storyboards.

1. Choose File > Open Project/Solution. Browse and locate the BaseBallWP7 folder that is inside the WP7Lesson04 folder. Double-click to open the solution file located within the BaseBallWP7 folder.

2. First, you’ll want to set up your workspace to make it animation-friendly. Select Window > Workspace > Animation Workspace, or press F6. This repositions your task panes, and puts the Objects & Timeline panel at the bottom of your workspace.

3. Locate and click the New button that is on the Objects and Timeline panel.

When the Create Storyboard Resource dialog box appears, type the name **BallToFirst**, and press OK.

_Naming the storyboard._
Take a moment to get familiar with the timeline. You’ll notice a current time marker (CTM) appears as a yellow beam vertically across the timeline. A time ruler at the top displays time in seconds from left to right. Unlike the timeline used in Flash, the time ruler works with seconds in Expression Blend. You will have an opportunity build an animation in the next part of this lesson.

Creating Keyspline animation

Keyspline animation involves the manipulation of an object over a given period of time. This could include an object’s position, dimensions, color and scale.

In this section, you will start the baseball moving from home plate to first base on the new storyboard’s timeline. You will eventually add other storyboards to get the baseball around the entire diamond.

1. Locate the Current Time Marker on the timeline, and drag the top triangle part to the 3-second mark on the timeline ruler.

Move the triangle at the top of the current time marker over to the 3 second mark.
LESSON 4

Designing for Windows Phone

Creating storyboard resources

2  Expand the LayoutGrid (by clicking on the arrow to the left of it in the Objects and Timeline panel) and select the Baseball object. Using your Selection tool, drag the selected baseball object and position it above first base. A keyframe is automatically created at the 3-second mark. Leave the baseball selected.

Now that you’ve created a single Storyboard that moves your baseball to first base, you’ll create additional storyboards for the other two bases.

3  Click the Add button in the Objects and Timeline panel. When the dialog box appears, type the new Storyboard name **BallToSecond**, and click OK. You’ll create a new animation with your baseball taking the same approach that you took in the previous exercise. This time you’ll move the ball to second base from home plate.

4  Drag the Current Time Marker (CTM) to the 3-second mark on the timeline. Position the baseball above second base at the top of the diamond. A keyframe is created at the 3-second mark.

5  Leave the baseball selected, and locate the Transform pane on the Properties panel. Click on the Scale tab. Retype the values of 1 in the horizontal and vertical scaling textboxes.

6  Press the Play button above the timeline to see your animation play back.

7  Click the Add button to create a third storyboard. Name the new storyboard **BallToThird**.

8  Follow steps 2-4, this time moving the ball to third base on the left side of the diamond, and setting the horizontal and vertical scale to .8.
Setting storyboard options

For each storyboard, you can set playback behavior options that save time and eliminate the need to create additional animation sequences. You can perform common tasks with a few check boxes and menus, including looping and even reversing storyboard animation. You’ll now add some of these behaviors to your storyboards to enhance their behavior.

1. Locate and click the Open a Storyboard button to the right of where the current storyboard name appears. Choose your original storyboard (BalltoFirst) to open that storyboard.

   ![Select the BalltoFirst storyboard.](image)

2. Once the storyboard appears, click directly on its name (at the top of the Objects and Timeline panel) to view the storyboard options in the Common Properties pane in the Properties panel on the right.

   ![Click on the Storyboard name to see additional options.](image)

3. Check the Auto Reverse checkbox. Once the timeline reaches the end, it will play back the animation in reverse until it reaches the beginning again.

   **Note:** If you do not see the Common Properties pane, make sure that you do not have letters in the Properties Search textbox.

4. Return to the Properties panel and locate the RepeatBehavior menu. This allows you to enter a number of repeats for your storyboard, including the option to repeat infinitely. Select Forever from the RepeatBehavior menu.

   ![Set the loop to be forever.](image)
Adding easing functions

A powerful and useful animation feature in Expression Blend is the built-in easing functions. These easing features allow you to add several basic and complex easing behaviors to your animations with a single click.

You’ll now take a look at these easing functions and apply them to a different storyboard.

1. Using the Storyboard selector, choose and open the BallToThird storyboard.
2. Locate the Baseball object, select the keyframe at the 3-second mark on the timeline. The Easing options should appear in the Properties pane on the right.
3. Select the EasingFunction tab to display the Easing Function menu. Click on the menu to view the available easing functions that you can apply to the selected keyframe.

4. Each function is available for in, out, or in/out (both). Select the Elastic icon under the Out column to apply an Elastic Ease Out.
5. Press the Play button above the timeline to preview the animation with the new easing function applied. The ball should spring into place above 3rd base.
6. Now you’ll try a different easing function on the same keyframe. Keep in mind you can only have one easing function on a keyframe at a time. Leave the keyframe selected, and click on the EasingFunction menu on the Properties panel.
7. Select the Back icon under the Out column, to apply it to the keyframe.
8. Press the Play button above the timeline to preview the animation with the new easing function applied. The ball will pass the ending point above third base, and then gradually move back into place.
Since you are finished creating the storyboards, click on the close box to the right of the named storyboard in the Objects and Timeline panel and then choose Window > Workspaces > Design.

Behaviors in Expression Blend

A helpful feature in Expression Blend is the availability of behaviors, which are pre-created interactive behaviors that save time and eliminate the need to write code to carry out common tasks.

You can easily apply behaviors to objects in your application for timeline control, button events, complex interactive behavior (such as drag and drop) and more. Behaviors are located in the Asset Library, and are applied via drag-and-drop directly to the Objects & Timeline panel.

A common behavior you’ll want to become familiar with is the ControlStoryboardAction behavior, which lets you stop, start, pause and resume storyboards when a specific trigger occurs in your application.

What are triggers?

Triggers, often called events in the programming world, represent any action that can cause a reaction. Common triggers you use each day are mouse clicks, rollovers, and key presses. Some triggers occur without user intervention, such as the loading of a specific control or some data in your application.

You can tie the behavior of a storyboard to a specific trigger so that it plays back or stops only when a certain action occurs in your application.

Locate the Assets panel and then select Behaviors > ControlStoryboardAction.

In the Objects and Timeline panel expand the BasesPanel layout container to reveal the button objects within.

Click and drag the ControlStoryboardAction icon from the Assets panel to the FirstButton located in the Objects & Timeline panel, and release. The new behavior appears as a child object of the FirstButton. Leave the ControlStoryboardAction object selected, and locate the Trigger pane in the Properties panel on the right.
In the Trigger pane, set the EventName to Click. In Common Properties make sure that Play is the selection for the ControlStoryboardOption and then choose BallToFirst from the Storyboard drop-down menu.

Choose Project > Run Project, or press F5. Click the First button to see the ball move to first base.

Close the phone emulator window, and return to Expression Blend.

Open the Assets panel. In the Behaviors category select the ControlStoryboardAction and drag it to the SecondButton in the Objects & Timeline panel. It appears in the Objects & Timeline as a child of the SecondButton.

In the Properties panel, you'll now set the trigger and storyboard action you want to occur. In the Trigger pane, make sure the EventName is Click.

In the Common Properties pane the set the ControlStoryboardOption to Play. Select the BallToSecond as the Storyboard.

Apply the ControlStoryboard behavior to the ThirdButton, and set it to Play BallToThird storyboard on Click.

Choose Project > Run Project. Press the FirstButton to start the ball moving to first base, and then click the SecondButton to make the ball switch directions, then press the ThirdButton.

Close the phone emulator when you are finished testing your project.

Return to Expression Blend and close the project.

Benefits of “hand-off” timelines

You may notice that when you clicked SecondButton (while the BalltoFirst animation was playing) the ball simply changed trajectory and moves toward second base without any jumps. This is handoff animation at work.

A handoff animation is one that allows one storyboard to interrupt another without causing disjointed motion. The second storyboard simply picks up where the first one left off. This allows storyboards to switch seamlessly from one to the other.
If you’ve ever worked with Flash or a similar timeline application, you’ve seen how switches between different timelines cause disjointed or fragmented motion, even when the timelines animate the same object. In Expression Blend, the same object animated across several timelines is still treated as a single independent object, and changes in trajectory are seamless even if a timeline is already in motion.

**Tip:** To insure handoff animation works as it should, avoid creating keyframes on the first frame of a storyboard’s timeline. This will always force the object being animated to a uniform start position, rather than allowing the previous storyboard to pass the current position along.

**Summary**

In this lesson you discovered how to create and edit a storyboard, or animation. You also found out how to set up easing functions to give animations a more natural movement.
LESSON 5
Working with the Visual State Manager

Add interactivity and functionality to your application by taking advantage of the Visual State manager in Expression Blend. By creating states you can have multiple property changes triggered by an event to occur simultaneously on the screen.

What you’ll learn in this module:

• Introduction to the included UI Controls
• Using the Visual State Manager to modify states and transitions
• Labeling buttons with text or graphical content
• Understanding style resources
• Creating custom UI Controls
Understanding the Visual State Manager

Changes in appearance are an essential part of a user experience. In Windows Phone applications, the creation, management and display of different states at any level is controlled by the Visual State Manager. You can work with the Visual State Manager using the States panel in Expression Blend.

Adding and modifying a UI Button control

In this lesson, you’ll add a pre-created UI Button from the Assets panel and modify it using the Visual State Manager. This will give you a feel for how easy it is to get up and running with UI controls, as well as the flexibility you have to change their behavior and appearance.

1. Choose File > New Project > Windows Phone > Windows Phone Application.
2. Name the project MyControls and browse to save it in your WP7Lesson05 folder; press OK. You will now add a folder to the Projects folder to hold images that will be used in this application.
3. From the Project menu item choose Add New Folder; a folder, highlighted so that it can be renamed, is added to the Projects panel. Name the folder Images.
4. Choose Project > Add Existing Item and browse to the WP7Lesson05 folder and select the image named GreenFish.png, and then choose Open. The images are added to your Projects folder.

Customizing a control

Expression Blend includes a number of existing UI controls like buttons and sliders that you can use immediately. The standard controls can be easily modified using the Visual State Manager, or completely re-skinned using style templates. Each control has a pre-created look, feel, and behavior, and you can add additional controls to your application using the Assets panel.

1. To see some of the available controls, locate the Assets panel, and select the Controls category. In the Controls library you see pre-built controls such as the Popup, ProgressBar, RadioButton, Slider, and more. These can be dragged and dropped directly to the artboard, and then customized to work in your application.

2. Select the Button control from the Tools panel and click and drag it anywhere on the artboard.
3 Right-click on the Button control that you just created and choose Edit Template > Edit a Copy. This makes a copy of the Button master template.

4 The Create Style Resource dialog box appears. Name your new control **FishControlButton**. Under the Define In options, leave This document selected. Click OK. You are now in the Button’s edit mode.

![Create Style Resource](image)

Creating a new style resource.

**Tip:** If you want to make this control available in other XAML documents in your project, choose Application instead This document to make the UI Button a global resource. Otherwise, the button is defined in the MainPage:XAML document only.

5 Click on the ButtonBackground in the Objects & Timeline panel. The ButtonBackground is one of the parts that make up your button. It is a Border control. The child container within the Border is called the ContentContainer and it contains the text label that appears on the button.

![Objects and Timeline](image)

The default template for the button control.

You might notice that some of the properties in the Properties panel are highlighted in yellow. You can see this in the Brushes pane. This indicates that the property is bound or linked to a style template. For this example you will reset the properties so that you can customize the Button further.
6 With the ButtonBackground selected, click on the Advanced options button to the right of Background in the Brushes pane; choose Reset. If you receive an error message about an animation error, ignore it. The error relates to a state change that you will correct later in this lesson.

Reset the Background property.

7 Select the Solid color brush and then using the color wheel change the color to a bluish green color. You can also enter the hex value #FF5CD6C8 in the Hexadecimal textbox.

Next, you’ll modify the color of the button, but only when it is pressed. For this, you’ll find out how to edit the Pressed state of the Button.

8 Select the States panel. This panel reflects each of the Button’s states or appearance changes for different types of mouse interaction. You can modify colors and appearance for each of the button’s existing states, or fine-tune transitions between states.
In the States panel, locate and select the Pressed state in the States panel.

Click on ButtonBackground in the Objects & Timeline panel, and then click on Background in the Brushes pane.

Select Solid color brush and using the color wheel in the Properties panel on the right side, set a new turquoise fill, or you can use the hex value #FFA8E4DD.

Press Ctrl+S to save your project, and choose Project > Run Project (F5) to test your changes. When the phone emulator appears, you see your button appear turquoise and change to a lighter turquoise when pressed.

Close the phone emulator and return to Expression Blend. The next step is to define a smoother transition between the starting (Base) state and the Pressed state. For this, you can define timed transitions between states.

The Pressed state should still be active. In the States panel, locate and click the Add Transition button on the Pressed state.

From the menu that appears, select the first option (* => Pressed). This defines a transition to the Pressed state from any other state within the button. A new Transition is added below the Pressed state in the States panel.
LESSON 5 Applying style templates

15 You’ll see an Easing function icon (for adding eases to your transitions), and a transition duration time. Double click on the transition duration indicator (which reads 0’s), and enter .5 (for half a second.) The transition from any state to the Pressed state will now gradually occur over .5 second.

Setting the transition time.

16 Save your project and choose Project > Run Project to see your new changes applied. The button now gradually fades into the Pressed state when the button is clicked and held.

17 Return to Expression Blend. Exit the template you’re currently editing by clicking the Button indicator at the top of the document window, or the Return to Scope button in the Objects and Timeline panel.

Applying style templates

If you’ve worked with Cascading Style Sheets (CSS), you’re familiar with the concept of creating a single style that can be applied to many elements so they all share a common look and feel. This same concept exists in the form of style templates in Expression Blend, which can give multiple controls a uniform appearance without sacrificing the underlying functionality.

This is essential if you have several buttons that all need to look the same. With style templates, you can apply a single style template to several controls without the need to perform the same visual changes on each one.

When you edit a UI Control (and make a copy of its template) you create a Style Template that can be applied to other existing UI controls in the application. You’ll now apply the look and feel you gave to your first button to the second button.

1 Create a second Button by selecting the Button Control from the Tools panel and clicking and dragging it out on the artboard, don’t worry about the size.

2 Right+click on the second button and choose Edit Template > Apply Resource. Your customized UI Button (FishControlButton) appears as an available style resource that can be applied to the Button. Select FishControlButton to apply the same look and feel from the first button to the second one.

Modifying the button

While each of your controls now shares a common look you may want to modify certain key elements, such as text label and button sizes.

1 Using the Selection tool, click on one of the buttons and then hold down the Shift key and click on the second button. Both buttons are now selected.

2 Locate the Layout pane, in the Properties panel, and change both the Width and Height to 160.
3 Click on the Advanced Properties button to the right of the Margin fields and click to select Reset.

Keep in mind, the ContentPresenter displays text-based content, which can be modified quickly and easily in the Properties panel. This label will be unique to that single button, and not affect the other buttons even though they share the same style template.

4 If your buttons are not positioned next to each other, use the Selection tool to do that now.

5 Select the left button that you created

6 In the Properties panel, locate and expand the Common Properties pane. Locate the Content field and type **Play** in place of the placeholder content (Button).

7 Click on the right button and enter **Pause** into the Content textbox.

8 Press Ctrl+S to save this file. Keep it open for the next part of this lesson.

Creating a custom UI control

The previous exercises have shown you how to place and customize Blend's pre-created UI controls, which is a great way to get up and running. You may, however, have already created an ideal design for a control that you’d like to use, so modifying an existing control may be a less direct way to achieve this.

For these situations, you can easily create UI Controls that have the same pre-built functionality of the provided UI Controls by converting graphical content to one of a number of different types of control templates (ie. Buttons, Checkboxes, sliders, etc.).

1 With the MyControls project still open, right-click on ContentPanel in the Objects and Timeline panel and choose Pin Active Container; a yellow border appears around the ContentPanel to indicate that any new items you create will automatically be placed inside of this container.
2 Click on the green fish image in the Images folder inside the Projects panel and drag it to the artboard. You will now turn the fish into a button.

3 Right-click on the fish image and choose Make Into Control. Name the Control **FishStyle** and choose Application, then press OK. You are now in the button template.

4 Click on the ContentPresenter in the Objects and Timeline panel, and then press Delete on the keyboard. In this case you do not need the text.

5 Exit the template by clicking on the Button breadcrumb at the top of the artboard, or the Return to Scope button in the Objects and Timeline panel.

---

**Adding a sound behavior to the button**

You will now add sound to the button.

1 Choose the Assets panel and select Behaviors

2 Click and drag the PlaySoundAction behavior to the fish button you just created.

3 In the Properties panel look for the Trigger pane and change the EventName to Click.
In the Common Properties pane select Choose an image (button with dots to the right of Source) and navigate to the WP7Lesson05 folder, and then double-click to select the Bubble.wma sound.

Change the volume to 1 and make sure that sound is turned on for your computer.

Press F5 to test your application, when you click on the fish the bubble sound occurs. Return to Expression blend when you are finished testing your application.

Adding animation

In this next section you will animate the fish.

Press F6 to change the workspace to the Animation workspace. Position the fish to be on the left side of the artboard.

Click on the New button on the Objects and Timeline panel. When the Create Storyboard Resource dialog box appears type SwimStoryboard and press OK.

In the Timeline click on the Current Time Marker (also referred to as the playhead) and drag it to the 1 second mark. Then click and drag the fish to another location on your artboard. Press the Play button to test your animation.

Experiment with different animations by repositioning the playhead and repositioning the fish control. With every movement a new keyframe is added. Keep in mind that you can also animate Opacity, Scale, Rotation and many of the other properties of the fish control.
5 When you complete your animation select the Storyboard name (SwimStoryboard) in the Objects and Timeline panel, and locate RepeatBehavior in the Properties panel. From the drop-down menu choose Forever.

Select the Storyboard name. Select a RepeatBehavior of Forever.

6 Select the Close Storyboard button on the Objects and Timeline.

Adding the Control Storyboard behavior

Now that you have created an animation you will want to create an event to play it.

1 Go to Assets > Behaviors > ControlStoryboardAction and drag the behavior to the Play Button that you created earlier.

2 Locate the Trigger pane and make sure the EventName is set to Click.

3 In the Common Properties set the Storyboard to SwimStoryboard.
4 Now drag another ControlStoryboardAction to the Pause button. This time set the ControlStoryboardOption to Pause, and the Storyboard in Common Properties to SwimStoryboard.

5 Test your new buttons by pressing F5 to run the application.

6 Return to Expression Blend and Choose File > Close Project.

Summary
In this lesson you discovered how to build and trigger various visual states in your application. You also discovered how to use behaviors to trigger those state changes.
LESSON 6
Adding Data to your Application

You can easily add sample data to your phone project. By adding sample data you can design the look and feel of information and be confident that, when connected to live data, your design will work successfully. In this next section you add sample data and then customize the look and feel of it in your application.

What you’ll learn in this module:
- Taking advantage of sample data
- Using Data in your application
- Editing the style template for your data
Using sample data in your project

In this section you will add information in the form of sample data to an application. By using sample data you can create the look and feel of real data and make styling changes that it will control the appearance of the data in your final application.

1. Save and close any open Expression Blend projects and then choose File > New Project > Windows Phone > Windows Phone Panorama Application.

2. Name the project **MyDataProject** and make sure it is saved into your WP7Lessons06 folder. Press OK.

3. Locate the Data panel on the right side of the workspace and click on the Create sample data button. Then click on New Sample Data.

4. In the NewSample Data dialog box enter the name **MyFriendsData**, leave the default values as they are, and then press OK. Two properties are added to your new data collection, Property1 and Property2. You will change these properties and add one new one.
5  Double-Click on text Property1 and change the txt to Name, and then click on the Change property type button to the right. Keep String for the property type and then select Name for the Format. Click on the bar that surrounds the Name property to close the dialog box.

6  Double-click on text Property2 and change the text to **Images**, then click on the Change property type button and select Image as the property type and then click on Browse to locate the pictures folder inside the WP7Lessons06 folder. Double-click on the pictures folder, you will not see any images in the folder, but you still must click on the Select Folder button.

7  You will now add a new property by clicking on the Plus sign (➕) to the right of Collection in the Data panel. Change the property name to Email and then keep the property type as String and change the Format to Email Address.
Select the Collection in the Data panel (the topmost item that holds the individual properties) and click and drag it to the ListBox that is in the first PanoramaItem screen. The default data is replaced with the new data you just created.

**Editing the Data Template**

In the ListBox is some data that we want to appear in a different container on the screen, to do this you will edit the template of this ListBox control.

1. Right-click on the ListBox and choose Edit Additional Templates > Edit Generated Items (ItemTemplate) > Edit Current. You can tell that are now in the template of the ListBox, by looking at the Objects and Timeline panel. The main container is now an ItemTemplate (ContentPresenter Template.)

2. With the Selection tool click on the name and the email address and Right-click and choose Delete. Now only the image remains in the ListBox.
3 Select the StackPanel in the Objects and Timeline panel. Scale the StackPanel and the image to a larger size to add some spacing around the images. The nature of a ListBox is to scroll, so don’t worry if all the images don’t fit into the ListBox control.

Note: Changes you make to the topmost image affect all others in the ListBox.

4 Select the image and right-click and choose Group Into > Border.

5 Click on the Properties tab. In the Properties panel add a 2 pt border (BorderThickness) on all sides. Makes sure to click on BorderBrush and then Solid color brush, then select White as the color.

6 Click on the image and choose Stretch > Uniform to Fill, located in the Common Properties pane.

7 Click on the ListBox breadcrumb at the top of the artboard to exit the template.
Click and drag to close up the ListBox so it is not taking up the entire screen. You will now put the additional properties outside this ListBox.

Since the ListBox is not in a grid or a canvas, you must make one now, or else the name and email properties will not have a place to go. Do this by right-clicking on the ListBox and choosing Group Into > Canvas.

After grouping the StackPanel into a Canvas, open the canvas up, by clicking and dragging the handle on the right, so that there is available space on the right side.

In the Data tab click on Details Mode button.
12 Click and drag the Image Property (from the Data tab) out to the space that is available on the right side of the newly created canvas. A grid is added to the Objects and Timeline, and it contains an Image control.

13 Select the Image control and click and drag the lower-right corner to resize the image to be as large as you can without exiting the Panorama.

14 Then, click and drag the Name property and position it under the image. Change the text size if you like.

15 Run the project (F5) and click on several images in the ListBox to see the details appear on the right.

Adding a Panorama background image

In this section you add a folder to your project and then add additional imagery that you will use as the background to the Panorama control.

1 Select Project > Add New Folder and name the folder Images.

2 With that folder still selected choose Project > Add existing Item and select the bluegrunge.jpg image located within the WP7Lesson06 folder.

Note: If you receive a message about the size of the file, press Yes.

3 Click on Panorama in the Objects and Timeline panel and then locate the Brushes pane in the Properties panel. Make sure that the Background brush is selected and then select the bluegrunge.jpg image from the ImageSource drop-down menu.

4 Change the Stretch to UniformToFill from the Stretch drop-down menu.
Choosing File > Save All. Keep this file open for the next part of this lesson.

Changing the Title and Headers

In this section you will change the Application name and the Headers on the Panorama and PanoramaItem controls.

1. Select the Panorama object in the Objects and Timeline panel.

2. Locate the Common Properties pane in the Properties panel and change the Title to My Gallery.

3. Now select the top PanoramaItem in the Objects and Timeline panel and locate the Common Properties pane again.

4. Change the Header to Summer.

5. Select the second PanoramaItem and in the Common Properties pane, change the Header to great times!

6. Choose File > Save All. Keep this file open for the next part of this lesson.
Adding data to the second panel

In an earlier exercise you switched from the Collection to the Details mode to drag individual properties on to a canvas (name and email.) Data added to your app using the Details mode can also be used in multiple PanoramaItems in the same application. In this section you select the second PanoramaItem and place a larger image in that panel.

1. In the Objects and Timeline panel double-click on the top PanoramaItem and rename it ThumbPanoramaItem.
2. Select the bottom PanoramaItem and rename it DetailPanoramaItem.

3. Select the DetailPanorama; the artboard displays the screen. Delete the existing ListBox.
4. Select Canvas from the Tools panel and click and drag a canvas that takes up most of the center section of the screen.
5. Make sure that the Data panel is forward and also that Details mode is selected.

6. Click and drag the Images property out to the DetailPanoramaItem, the first image appears.
7. Switch to the Selection tool, and click and drag to resize the image and make it larger.
8. Press F5 to run your project. When you click on the small images in the ListBox, a larger thumbnail appears on the same screen. At the same time a much larger image appears on the second screen.

Summary

In this lesson, you discovered how to use sample data to create the look and feel of data in your application. You also discovered how to edit the data template and take advantage of the Details mode for additional functionality.
LESSON 7
Creating the Flickr4Fun app

In this section you find out how to incorporate much of what you have learned into a Flickr Phone application that will search for images based upon a keyword and also allow you to add talk bubbles and save the image to your phone.

What you’ll learn in this module:

• Using the WrapPanel
• Using the tile brush feature
• Adding references for additional functionality
• Testing your app
Starting your application

In this lesson you turn a non-functioning basic pivot layout into a working Windows Phone application. You will have the opportunity to build the components and then hook them up to behaviors that will add functionality to the application.

1. Start the project by launching Expression Blend. Choose File > Open Project/Solution and locate the FlickrFun_Start folder inside the WP7Lesson07 folder. Open the folder and double-click on Flickr4Fun_Start.sln. If you receive a warning message, press Yes that you do want to open the application.

You will begin this project by assigning the correct title and header information to the pivot and PivotItem controls in your application.

2. In the Objects and Timeline panel expand the LayoutRoot, and then select the pivot control. In the Common Properties pane of the Properties panel locate the textbox for Title and type FLICKR4FUN in all caps. This follows the METRO style guide for text in a Windows Phone application.

3. Expand the pivot control and select the top PivotItem that you see listed in the Objects and Timeline panel. In the Common Properties for the PivotItem control, change the Header to search flickr. This should be in lowercase.

4. Select the second PivotItem and change the Header to add bubbles.

Adding containers and objects

You will now add a WrapPanel and some images to the first PivotItem.

A WrapPanel allows objects to be placed on multiple lines. When an object overflows off the edge of the panel, it is wrapped to the next line. As you add more objects, the WrapPanel layout panel continues to wrap the objects until it runs out of space. Only then will it clip additional objects.

When completed the first PivotItem will be the screen where the Flickr results are displayed.

1. Expand the top PivotItem control so that you see the Canvas object contained within.

2. Right-click on the Canvas and choose Pin Active Container, this assures that the next item you create becomes a child of that container. You will now create a WrapPanel inside the Canvas.
Designing for Windows Phone

LESSON 7

Using the Tile brush for images

**Note:** The WrapPanel is not a default control in Expression Blend, in order to access the WrapPanel in your own applications make sure that you download http://silverlight.codeplex.com/releases/view/60291. Once installed you will need to choose Project > Add Reference and navigate to the C:\Program Files\Microsoft SDKs\Windows Phone\v7.0\Toolkit folder and select the Windows Phone Toolkit.

3 Since the WrapPanel is not in the default set of containers you will need to access it using the Assets section of the Tools panel. Click and hold on Assets ( massa ) in the Tools panel, it is the double-arrow icon at the bottom of the Tools Panel.

4 In the Search menu type Wrap until you see the WrapPanel control appear. Select the Wrap Panel and click and drag it out into the Canvas.

5 Resize the WrapPanel by entering the following values into the Layout pane inside the Properties panel. Width 440, Height 510, Left 0, Top 75. Keep in mind that all Margins should be at zero. The space at the top will be used for a TextBox later in this lesson.

![Layout pane](image)

6 Right-click on the WrapPanel, in the Objects and Timeline, and select Pin Active Container.

7 Select the Border object from the Tools panel. It is one of the hidden containers inside the Grid tool.

![Border object](image)

8 Double-click on the Border control (in the Tools panel) to put it into the WrapPanel. In the Properties panel locate the Layout pane and change both the Width and Height to the value 180. You will now put an image inside the border and size it to fit the border.

Using the Tile brush for images

It is important that there be some images in the initial screen before any searches are created. For this example you will use some images of sunsets that are already loaded into the project.

1 With the Border selected in the Objects and Timeline panel, choose Tile brush. It is located in the Brushes pane of the Properties panel.
Choose UniformToFill for the Stretch and using the drop-down menu, select Sunset01.jpg for the image background tile. You will now copy the Border three times.

Make sure that you are on the Selection tool, and that the Border control is selected, and then press Ctrl+C, and then press Ctrl+V three times. You now have a total of four sunset images.

Select one of the Borders in the WrapPanel, in the Objects and Timeline panel, and then Shift+click to select the remaining three.
5 Insert the cursor into the left margin textfield (in the Layout pane in the Properties panel) and enter 10, press Tab to move to the right margin and enter 10 again. Continue to the top and bottom margins also entering 10 for those values.

7 With all four borders still selected, customize the Border control by selecting BorderBrush in the Brushes pane of the Properties panel, and then selecting the Solid color brush; click on white in the color pane. You can also enter white as the border color by typing #FFFFFF into the hexadecimal textbox at the bottom of the color pane.

Note: The first two values in the hexadecimal value control the Alpha, or transparency of the object.

8 Change the BorderThickness to a value of 2 px in all four borders in the Appearance pane of the Properties panel.

9 Now select second Border control and in the Objects and Timeline panel, and choose Tile brush. It is located in the Brushes pane of the Properties panel.
10 Choose UniformToFill for the Stretch and using the drop-down menu, select Sunset02.jpg for the image background tile.

11 Repeat this procedure for the last two Border controls, changing the the third border's ImageSource to sunset03.jpg and the fourth's to sunset04.jpg Choose File > Save All and keep the project open.

Adding the TextBox

You will now add the TextBox object which will be used for the search.

1 In the Objects and Timeline panel Right-click on the Canvas in the top PivotItem and select Pin Active Container.

2 Select the TextBox from the Tools panel, it is the hidden object in the TextBlock tool. Keep in mind that a TextBlock is a text container that does not allow user input, whereas the TextBox allows the user to type into the box. Click and drag the TextBox into the space above the WrapPanel.

3 In Common Properties type Search into the Textfield, and adjust the size and position as necessary, but no exact specifications are needed.
Adding a loading screen

In this next step you will create a simple screen that will appear only while the search is occurring. To do this you will create a new grid inside the LayoutRoot item and show it only when in a loading state.

1. Right-click on the LayoutRoot in the Objects and Timeline panel, and then select Pin Active Container.

2. Select the Grid from the Tools panel and click and drag out in the center of the artboard.

3. In the Properties panel, change the <No Name> text to **grdLoading**.

4. Click on the Advanced Options button to the right of margins (in the Properties > Layout pane) and choose Reset. This spans the grid across the entire LayoutRoot.

5. Click and drag a TextBlock out of the Tools panel to the approximate center of the artboard, and type **LOADING** in all caps. In the Properties > Text pane you can change the text size to **Segoe WP Black**, size **22**, but no particular size or font is required.

6. In the Properties > Text pane, change the text alignment to Center by selecting the Paragraph tab and selecting Center Alignment from the Text alignment drop-down menu.

**Note:** If you do not see the Alignment menu make sure that you have the Selection tool active and the TextBlock selected.

7. In the Layout pane click on the Center option for both the Horizontal and Vertical Alignment of the TextBlock. An exact position is not important, so feel free to adjust the location of your **LOADING** text.
Select the grdLoading grid in the Objects and Timeline panel, and then choose Background from the Brushes pane (located in the Properties panel) and then choose Solid color brush; click on Black in the color panel. You can also enter the value of #FF000000 in the hexadecimal textbox as well.

In the Appearance pane, change the opacity of the grdLoading to 75%, and choose Collapsed from the Visibility drop-down menu. By collapsing an object you can choose to have it hidden until an event triggers its visibility.

Keep the Loading text hidden until needed.

**Creating a Loading State**

In this section you will create a state that shows your loading screen only when the application is searching on Flickr.

1. Go to the States panel and select the Add state group button in the upper-right. A VisualStateGroup appears. You can keep that default name for this lesson.

2. Click on the Add state button two times to create two states. Name the first state Normal and the second state Loading.

3. Select Normal in the States panel. The application should look as it will when someone comes to the screen for the first time. The grdLoading grid is supposed to be collapsed at this point, if it is not, choose Collapsed in the Visibility section of the Appearance panel.

4. Select the Loading state in the States panel, and then select the grdLoading grid in the Objects and Timeline panel, and then go to the Appearance pane and change the Visibility to Visible. The grdLoading will now only be displayed when the state is called by an event, which you will set up later in this lesson.

5. Select Base in the States panel to turn off the state recording and then choose File > Save All.
Adding a custom behavior

As a designer you can create the look and feel of your application and then request code that adds functionality from a developer. In this case the developer took the code and packaged it up in a behavior, making it easy for a designer to add and implement a search on Flickr. You can easily take advantage of behaviors by referencing them in your project. In this section, you will add a reference to add some Flickr behaviors.

1. Choose Project > Add Reference and navigate back to the WP7Lesson folder and double-click to open the folder named FunWFlickr.Behaviors.
2. Locate the file named FunWFlickr.Behaviors.dll inside the\Bin\Debug folder and click OK.
3. Choose Project > Build Project.
4. Go to Assets > Behaviors and note that four new Flickr behaviors have been added to the existing behaviors.

Applying the Search Behavior

You will now apply one of the new behaviors to your application.

1. Select the Assets > Behaviors and locate the FlickrSearchBehavior and drag it on top of the TextBox. Within the Properties panel note that there is a Results pane with specific options relating to the functionality of this behavior. To the right of the CanvasField property there is an ellipse button (...). This is called the Select an element button and will allow you target the container you want to populate with search results.
2 Click on the Select an element button to the right of the CanvasEdit property. When the The Select Element window appears scroll down to select cnvEdit, and then press OK.

3 Click on the Select an Element button for the PanelResults property and then click on the WrapPanel and click OK. Now click on the Select an Element button for the PivotContainer property, click on the main pivot control and click OK. You are essentially creating a road map from the initial pivot container to the WrapPanel where the results will be displayed.

4 In the Search section choose your Loading state for the StateNameSearching, and Normal for the StateNameShowResults property.

5 Test your search by pressing F5 and type a search item in using the phone emulator keyboard. If the behavior is set up correctly you see the results in the Border containers. If you click on an image it appears in the second PivotItem.
LESSON 7
Creating the bubble buttons

Adding the bubble TextBox

In this section you add the textbox that will be used to enter the bubble text.

1. Navigate to the second PivotItem by selecting it in the Objects and Timeline panel.
2. Right-click on the Canvas control located within the second PivotItem and choose Pin active container.
3. Select the Textbox on the Tools panel and place your cursor on the artboard and then click and drag to draw a Textbox.
4. Name the textbox **txtBalloonText**, and using the Selection tool, position it so it is flush with the left side of the canvas, leaving room for the talk bubbles on the right.
5. Switch to the Selection tool and then double-click on the TextBox. This highlights the text. Change the text to **Bubble Text**.

5. Choose File > Save All and keep the file open for the next part of this lesson.

Creating the bubble buttons

In this section you will use an existing piece of art to make a custom button.

1. If you are not already in the second PivotItem navigate to it now by selecting it in the Objects and Timeline panel. You will now create a folder and add an image to it that will be converted into the talk bubble button.
2. Choose Project > Add New Folder. In the Projects panel change the folder name to **images**.
3. With the folder still selected, choose Project > Add Existing Item. Navigate to the WP07Lesson folder and select the image named TalkBubble.

Even though you can click and drag to add an image from the Projects pane to the artboard, it is sometimes better to use an Image control. The image control allows you to position and size of the image before placing it on the artboard.

4. Click on Assets in the Tools panel and then type **imag** in the Search textbox. Select the Image control.
5. Once the Image control is selected, click and drag to the right of the TextBox to create an empty image control that is about 40 pixels high and 60 pixels wide.
In the Common Properties pane choose the TalkBubble01 image as the Source and leave the Stretch at Uniform. You will convert the talk bubble image control into a button control.

![Insert the bubble artwork.](image)

Right-click on the talk bubble image control and select Make Into Control. When the Make Into Control window appears, simply press OK. The default action is to create a button control, and it is not necessary to name the style for the project that you are working on. You are now in the new button style, or template.

Select the ContentPresenter in the Objects and Timeline panel and then press Delete. Exit the template by clicking on Button in the breadcrumbs at the top of the page.

Make sure that you are on the Selection tool and select the button that you just created. Using the Properties panel change the button name to **ButtonBalloonLeft**.

![Rename the button.](image)

Select Edit > Copy and then Edit > Paste. When you copy and paste in Expression Blend a copy is placed directly on top of the existing object.

Select the new button named ButtonBalloonLeft_Copy and change the name to ButtonBalloonRt.

Locate the Transform panel and select the Flip tab. Click on the Flip X axis button.

Click and drag to position the ButtonBalloonRt above the ButtonBallonLeft.
Creating a delete balloon button

In this next section you create a button that will delete any existing balloons. In this section you will have the opportunity to use the drawing tools, and then convert the objects you created into a working button.

1. Select the Rectangle tool and click and drag on the artboard to create a square that is approximately 30 px x 30 px.

2. In the Brushes pane, select Fill and then click on the No brush button.

3. Select Stroke and then click on the Solid color brush. When the color pane appears click on white, or enter #FFFFFF into the hexadecimal textbox.

4. With Stroke still selected change the StrokeThickness to 2. You will now create the X that will finish the Delete button.

5. Select your Pen tool and click in the upper-left corner of the rectangle and then to the lower-right.

6. Hold down the Control key and click off the path that you just created. By holding down the Control key you temporarily switch to the Selection tools so that you can deactivate the path and start a new one.

7. Now click on the upper-right corner of the rectangle and then click in the lower-left. You now have two paths that have been added to the project.

8. Using the Objects and Timeline panel click on one of the Paths and then Shift-click on the other.

9. Click on Stroke and make sure it is using the Solid color brush and then change the color to White, or #FFFFFF. Change the StrokeThickness to 2.

10. In the Objects and Timeline panel Shift+click to add the rectangle to the selection.

11. Right-click and select Group into > Canvas.
12 Right-click again and select Make Into Control. As a default button is selected, the style does not have to be named in this example so press OK.

13 Since this button does not require descriptive text, delete the ContentPresenter.

14 Exit the button template by clicking on Button in the breadcrumbs at the top of the workspace. You are now in the working project.

15 Change the name of the new button to **DeleteButton**.

16 Choose File > Save All and keep the file open for the next part of this lesson.

**Creating the Save to Phone button**

The last button that you create will use the standard button template and have a pre-created behavior applied to it.

1 Select Button from the Tools panel and click and drag to create a button that is about **285 px x 70 px** on the canvas.

2 Using the Name textfield at the top of the Properties panel, rename this button **SaveToPhone**.

3 Using the Selection tool, position the SaveToPhone button so that it is in the lower center of the Canvas container.

4 To change the content either double-click on the button or enter the following text in the Content textbox in the Common Properties pane, **Save to Phone**.

5 Add the save functionality by going to Assets > Behaviors and dragging the FlickrSavePhotoAction to the SaveToPhone button.

6 Choose File > Save All and keep the file open for the next part of this lesson.

**Adding the bubble text behavior**

In this section you add the behavior that creates the bubble text.

1 Go to Assets > Behaviors and locate the behavior named FlickrEditPhotoBehavior and drag it to the cnvEdit.

2 Notice the options that appear in the Properties panel. You will now assign the target so that the behavior can function.

3 For ButtonBalloonLeft click on the Select an element button and click on the ButtonBalloonLeft object.

4 For ButtonBalloonRight use the Select an element button to select the ButtonBalloonRt.

5 For the ButtonClearBalloons use the Select an element button to select the Delete Button.
6 For the TextBoxBalloonText use the Select an element button to select the txtBalloonText button.

7 Press F5 to test your working application.

8 Using the phone keyboard, type in a search term, and select an image.

9 Using the phone keyboard, type text that you would like to appear in a talk bubble and then select either a left or right bubble. The talk bubble is added to the screen.

10 Experiment with deleting and adding additional bubbles.

Summary

In this lesson you discovered how to design a working application by collaborating with a developer. By taking advantage of this workflow you can add functionality to your application while controlling the look and feel.
Index

A
alignment
  horizontal 79
anchor point 32, 35
animation 61
  keyspline 46
Appearance 77
artboard 11, 16
  importing 20
assets
  importing 20

B
behavior 50, 81, 86
  custom 81
  reference 81
Border 75, 77
  BorderThickness 77
BorderBrush 43
Border control 43
breadcrumbs 84, 86
brush 56
  Solid color 56
brushes 77
button 41, 83
  custom 83
  modifying 54, 58

C
Canvas 24, 41
Canvas control 38
clone 27
codeplex.com 75
Collapsed 80
ContentPresenter 84
Control 84
  Make Into 84
copy 84
corner radius 43
CTM 47
Current Time Marker 47

D
data template 67
Direct Selection tool 34

E
easing function 49, 58
  easing functions 49
Expression Blend 10, 16
  importing 20
  selections 17
  workspace 10

F
Fill 85

G
grid 24
  Grid 24
  Grid control 38
    row 39
  Group into 85

H
header 71

I
Illustrator 20
Image 83
Intellisence 17

L
layout controls 38
  Layout pane 42
ListBox 23, 68
loading screen 79

M
Microsoft SDKs 75

N
naming conventions 25
  naming objects 25
No brush 85

O
Objects and Timeline panel 47, 83
opacity 80

P
Panorama background image 70
  paste 84
Pen tool 31, 85
Photoshop 20
Pivot 22
  PivotItem 23, 74, 82
  primitive shapes 25
projects 12
properties 26
  Properties panel 14

R
raster 20
RepeatBehavior 48
resizing 29
rounded corners 28

S
sample data 65
search 14, 29
  Select an element button 81
  Selection 84
  Silverlight 22
  snap grid 24
Solid color brush 27, 85
sound 60
StackPanel 38, 41, 43, 69
storyboard 45, 62
  hand-off 51
  options 48
stretch 76, 78, 84
  UniformToFill 70
stroke 27
StrokeThickness 28, 85
style templates 58

T
template 84
text 79
  alignment 79
  TextBlock 79
  TextBox 83
  Tile brush 75
title 71
transform 29
  Transform 29, 84
  Flip 84
  triggers 50

U
undo 29

V
vector 20
View
  Design 16
  XAML 16
visibility 80
VisualStateGroup 80
Visual State Manager 53, 54
W
Windows Phone application 8
Windows Phone Databound 8
Windows Phone Panorama application 9
Windows Phone Pivot application 9
Windows Phone templates 8
workspace
reset 24
WrapPanel 74, 75, 82

X
XAML 16, 17, 38